Ooyala-hosted Player V4 Resources

This topic describes the Player V4 resources (core player, plugins, and skin resources) that you can use when you embed Player V4 on a web page. If you want to host these resources yourself (instead of Ooyala), see Hosting Player V4 Resources.

Ooyala Resource Paths

The Ooyala Player is hosted, distributed, and maintained on URL paths. These paths are automatically updated with new Player V4 releases and are subject to our 99.9% uptime SLA.

production

The following path is recommended for most Ooyala customers:

//player.ooyala.com/static/v4/production/

Note: Use this path only if your site does not have mixed content conditions (refer to this Google article) running over HTTPS.
This path is typically one release behind the latest Ooyala version. Ooyala keeps this path up to date but it does not contain the very latest player updates. This approach allows you to test your site on a staging environment with the production/latest version (see below) to verify the effect of player updates on any customizations. Example: //player.ooyala.com/static/v4/production/core.js

production/latest

The following path contains the latest Ooyala player version that has been certified for release.

//player.ooyala.com/static/v4/production/latest/

Note: Use this path only if your site does not have mixed content conditions running over HTTPS.
This path is recommended for Ooyala customers who need capabilities only available in the most recent release. Example: //player.ooyala.com/static/v4/production/latest/core.js

Static Ooyala-Hosted Player Paths

The Ooyala player is also hosted on static paths.

stable/latest

The following path is required for mixed-content conditions:

//player.ooyala.com/static/v4/stable/latest/

This path is set indefinitely to Player V4 Web v4.10.6, which is last player version that does not cause browsers to enforce mixed content rules with Flash playback. Example: //player.ooyala.com/static/v4/stable/latest/core.js

stable/version

The Ooyala Video Player is also hosted on version-specific paths (stable/#.#.#) for each player release (refer to the Ooyala Player V4 Release Notes for details). Using the static player paths is not recommended, as you will miss getting important player software updates automatically. If you point to specific player versions, you will be entirely responsible for manually updating player resources to newer versions. Example: //player.ooyala.com/static/v4/stable/4.13.4/core.min.js

List of Player V4 Resources

At a minimum, you must load the Core Player and at least one video plugin for Player V4 to function properly. If you do not load at least one video plugin, your player will not play videos.
Note: Wherever you see url_where_hosted in sample code, replace this (in your code) with the URL that points to where the resource is hosted. For a list of Ooyala-hosted paths, see Ooyala-hosted Player V4 Resources. The URL can point to a location on the same host (internal link) or on a separate host (prefixed with http:// or https://). If you host resources yourself (see Hosting Player V4 Resources), be sure to check for any path dependencies within the files.
Resource Name / Location Description
Core Player url_where_hosted/core.min.js Required.
Skin Resources    
HTML5 Skin url_where_hosted/skin-plugin/html5-skin.min.js Customizing the Player V4 Appearance
Note: To view the source in GitHub, see https://github.com/ooyala/html5-skin.
Skin CSS url_where_hosted/skin-plugin/html5-skin.min.css Customizing the Player V4 Appearance Using CSS
Skin Config File url_where_hosted/skin-plugin/skin.json
Note: skin.json is no longer required for the Ooyala Player skin to be used. Do not specify skin.json if you want to use the Player skins in Backlot. If skin.json is included at the page level, it will overwrite all Backlot player settings in the Publish tab.
Customizing the Player V4 Skin with skin.json
Skin iFrame url_where_hosted/skin-plugin/iframe.html Embedding Player V4 in an HTML iframe
Localization Files
  • url_where_hosted/skin-plugin/en.json
  • url_where_hosted/skin-plugin/es.json
  • url_where_hosted/skin-plugin/zh.json
Localizing the Player V4 UI provides instructions for adding your own localization files.
Images and Fonts
  • url_where_hosted/skin-plugin/assets/images/ooyala-watermark.png
  • url_where_hosted/skin-plugin/assets/images/ooyala.png
Image and font resources are required for the player skin to appear properly. In general, image and font files can be found in the GitHub repository at:
  • html5-skin/assets/fonts
  • html5-skin/assets/images
Video Recommendation (Discovery) plugin url_where_hosted/other-plugin/discovery_api.min.js Discovering Content in Player V4
Video Plugins   Loading Video Plugins
Note: At least one video plugin is required.
Bitmovin Video Plugin for DASH and HLS Player V4 Version 4.11.13 or higher
  • url_where_hosted/video-plugin/bit_wrapper.min.js
Player V4 Version 4.10.6 or earlier (required for mixed content conditions)
  • //player.ooyala.com/static/v4/stable/latest/video-plugin/bit_wrapper.min.js
  • This plugin is required for Live DVR (HLS streams only).
  • For DASH video, you must use the AAC or mp4a.40.2 audio codecs.
  • This plugin is not used with Safari or Safari Mobile. Playback on these browsers requires the main_html5.js plugin.
  • For this release, this plugin does not support Live closed captions for HLS.
Note: The order of the video plugins represents the order of priority for the plugin usage. For HTML5 video, we recommend loading the bit_wrapper.min.js first, followed by main_html5.js.
Main Video Plugin for HLS and MP4 url_where_hosted/video-plugin/main_html5.min.js Loading Video Plugins
OSMF Flash Video Plugin for HDS (Deprecated) url_where_hosted/video-plugin/osmf_flash.min.js Loading Video Plugins
Note: The Flash HDS plugin does not currently support IMA Ad Rules.
Note: The OSMF Flash Video Plugin for HDS for Player V4 has been deprecated and is scheduled to be disabled. For details and alternatives, see the OVP Release Notes.
Akamai HD Video Plugin for Akamai Packaged HDS (Deprecated) url_where_hosted/video-plugin/akamaiHD_flash.min.js Loading Video Plugins
Note: The Akamai HD Video Plugin for Akamai Packaged HDS for Player V4 has been deprecated and is scheduled to be disabled. For details and alternatives, see the OVP Release Notes.
Ooyala Player Plugin for YouTube iFrame url_where_hosted/video-plugin/youtube.min.js Playing YouTube Videos in Player V4
Ad Plugins   Ads in Player V4
Ooyala Pulse Ad Plugin url_where_hosted/ad-plugin/pulse.min.js Ooyala Pulse Ad Plugin
Ooyala SSAI Pulse Plugin for Live Ad Insertion url_where_hosted/ad-plugin/ssai_pulse.min.js Ooyala Pulse Live Stream Integration (SSAI)
Note: It is assumed that if the SSAI Pulse plugin is loaded that the stream will have server side ads inserted.
Google IMA Plugin url_where_hosted/ad-plugin/google_ima.min.js Google IMA Ad Plugin

To view the source in GitHub, see https://github.com/ooyala/html5-ad-plugins/blob/master/js/google_ima.js.

FreeWheel Plugin url_where_hosted/ad-plugin/freewheel.min.js FreeWheel Ad Plugin

To view the source in GitHub, see https://github.com/ooyala/html5-ad-plugins/blob/master/js/freewheel.js.

Note: To support FreeWheel ad playback, you must also include the Main Video Plugin. See Loading Video Plugins.
VAST and VPAID Plugin url_where_hosted/ad-plugin/ad_manager_vast.min.js VAST and VPAID Ad Plugin

To view the source in GitHub, see https://github.com/ooyala/html5-ad-plugins/blob/master/js/ad_manager_vast.js.

Note: To support VPAID ad playback, you must load the Main Video Plugin first among the video plugins.
Analytics Plugins   Analytics in Player V4
Adobe Analytics (Omniture) Plugin
  • url_where_hosted/analytics-plugin/VideoHeartbeat.min.js
  • url_where_hosted/analytics-plugin/AppMeasurement.js
  • url_where_hosted/analytics-plugin/VisitorAPI.js
  • url_where_hosted/analytics-plugin/omniture.min.js
Adobe Analytics (Omniture) Plugin
comScore Plugin Contact your Ooyala account manager for access to this plugin. comScore created and maintains this plugin. comScore Analytics Plugin
Conviva Analytics plugin
  • url_where_hosted/analytics-plugin/conviva-core-sdk.min.js
  • url_where_hosted/analytics-plugin/conviva.min.js
Conviva Analytics Plugin.
Note: You must specify conviva-core-sdk.min.js before conviva.min.js.
Google Analytics plugin url_where_hosted/analytics-plugin/googleAnalytics.min.js Google Analytics Plugin
Nielsen Analytics plugin url_where_hosted/analytics-plugin/Nielsen.min.js Nielsen Analytics Plugin
YOUBORA Analytics Plugin //smartplugin.youbora.com/v5/javascript/ooyalav4/stable/sp.min.js YOUBORA Analytics Plugin
Note: NPAW maintains the YOUBORA Analytics plugin for Player V4.
Other Feature Plugins    
Playlists plugin url_where_hosted/other-plugin/playlists.js Using Playlists in Player V4

Was this article helpful?