Overriding the Default VisualOn Library For Android Apps

If your implementation requires a VisualOn library that is not specifically supported by the SDK, use the following steps to turn off the version check option in the SDK.

Warning: Ooyala only confirms integration with the default libraries.
Warning:

As of April 1, 2016 the Ooyala Android SDKs have been shipping with Google ExoPlayer libraries instead of the VisualOn libraries. While there are steps that you will need to take, moving to ExoPlayer will provide a more consistent, higher quality HLS and MPEG-DASH playback experience for VOD and live streams on Android devices.

As of August 1, 2016, Ooyala will no longer support the HLS player integration with VisualOn or provide bug fixes or improvements specific to VisualOn libraries.

In order to upgrade, you will need to
  1. Open the VisualOn integration app project.
  2. Open the main activity source file and add the following line below the visualOnConfiguration statement:
    visualOnConfiguration.disableLibraryVersionChecks = true;

    This step is shown in the following code sample:

    VisualOnConfiguration visualOnConfiguration = new VisualOnConfiguration.Builder().build();
    visualOnConfiguration.disableLibraryVersionChecks = true;
    Options.Builder builder = new Options.Builder().setVisualOnConfiguration(visualOnConfiguration);
    Options options = builder.build();               
  3. Run the app and confirm the video plays correctly with the new library.

Was this article helpful?